Flash 8 or higher is required for viewing e-cards. Click here to download a free version of Flash.